Jump to content


Photo
- - - - -

Rev 3 Reluctant To Change Gear


  • Please log in to reply
4 replies to this topic

#1 scraggydog64

scraggydog64

    Advanced Member

  • Site Supporter
  • 123 posts
  • Location:North East
  • Bike:Mont 4RT
  • Club:Durham County

Posted 13 July 2008 - 07:30 PM

Hello

I have an 06 Rev 3 250. The gear selection is terrible and finding neutral is very hard. I goes through the gears perfectly without the engine running. The clutch works fine in terms of controling the drive. I use Dextron 3 AFT in the gear box.

I am assuming it is the clutch. I stripped it down and there are no groves in the basket. I cleaned the steel plates with emery cloth to remove any glaze as this used to work on my old 315 Mont. I eventually replaced the friction plates on the Mont - problem solved.

Has anyone had a similar problem with their Beta? If so what did you do? If it is the clutch any advice on where to get one and how much it cost?

Thanks in advance.


Scraggydog.


Ads By Google User is online

Ads By Google
  • Ad Bots


Don't want these Ads? Why not help support TC and sign up as a Trials Central Supporter?

#2 johnkennedy

johnkennedy

    Member

  • Members
  • PipPip
  • 90 posts
  • Location:Fort William
  • Bike:2008 beta 250
  • Club:lochabermcc.com

Posted 13 July 2008 - 08:26 PM

my bike and all other previous bikes (sherco and a gasgas) were very difficult to change into nuteral when the engine is running. they are like this to prevent the gear selector selecting nuteral if it hits a rock. and on my bike the change between 1st and 2nd is a little sticky, i recon this is for the same reason
A Good trialist learns from his own mistakes,
A Great trialist learns from others.

#3 fkrisztian

fkrisztian

    Member

  • Members
  • PipPip
  • 80 posts
  • Location:Romania
  • Bike:'04 Beta Rev3 250cc
  • Club:-

Posted 13 July 2008 - 08:57 PM

my bike and all other previous bikes (sherco and a gasgas) were very difficult to change into nuteral when the engine is running. they are like this to prevent the gear selector selecting nuteral if it hits a rock. and on my bike the change between 1st and 2nd is a little sticky, i recon this is for the same reason

Yep, me too. I think that this is normal.

#4 mrmoog

mrmoog

    Member

  • Members
  • PipPip
  • 33 posts
  • Location:Gloucestershire
  • Club:Cirencester

Posted 13 July 2008 - 10:15 PM

when did you last change the gear oil? it's time to change the oil if your having problems changing gear
How was i to know she had a wooden leg

#5 tilertrialler

tilertrialler

    Advanced Member

  • Site Supporter
  • 160 posts
  • Location:hants
  • Bike:fantic 200

Posted 14 July 2008 - 12:19 PM

I have an 06 beta , I go into 1st ,up to 2nd then gently knock down into netural, seems to work fine, 2nd to 3rd ,I sometimes get 2 clicks and i am unsure if I have gone into 4th , they way the selectors work I dont think I can go 2 gears in one lift is that true??




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users