Jump to content

mike1983

Beta evo won't run

Recommended Posts

Hi I've got a beta evo 250 2011 it's not been used over Xmas so I've removed the carb to clean with compressed air now it will only run and rev clean with the choke on?? If no choke the bike bogs down and stalls there is plenty of fuel coming from the fuel line and just fitted a new plug with good spark any ideas wot the problem is? 

Share this post


Link to post
Share on other sites

If the bike was running good before you took the carb apart, then you have obviously done something wrong. One of your jets is blocked? Take the jets out and look thru them for a blockage. Float's properly set?

Share this post


Link to post
Share on other sites

If it has to run on choke it's not getting enough fuel or more than likely  it's got too much air - it'll be an air leak from the carb to engine... Is the rubber boot between the carb and engine the right way round?...on the 4t it is designed to fit only one way round...there is only a slight difference on each end of the boot but there is a difference.

Share this post


Link to post
Share on other sites

I've just fitted a brand new pilot jet and no better the bike did ever so slightly bog after ticking over for a while at sections but would never bog enough to cut out.... 

Share this post


Link to post
Share on other sites

Not sure if it will make a difference but the fuel tank often gains pressure and makes a hissing sort of noise until I open the tank filler cap 

Share this post


Link to post
Share on other sites
2 hours ago, mike1983 said:

Not sure if it will make a difference but the fuel tank often gains pressure and makes a hissing sort of noise until I open the tank filler cap 

You may have found it then. Try running it with the cap off. If that solves it, you've got a blocked breather.

  • Like 1

Share this post


Link to post
Share on other sites

Spot on,if the air cannot get into the fuel tank through the breather(it works both ways as well as letting fuel vapour out) the bike may run for a while then build up a partial vacuum and prevent the fuel from draining under gravity through the fuel tap and into the carb.

Share this post


Link to post
Share on other sites

its sounds to me like when you cleaned the carb you have blown out the brass needle jet that sits in the middle of the carb that the needle  runs up and down in,its a very loose fit and easily comes out

Share this post


Link to post
Share on other sites

The little brass piece the needle goes in is still there cleaned carb again and tried it without the fuel cap but still won't run only with the choke on?? 

Share this post


Link to post
Share on other sites

this may sound daft but have you check your fuel has I spent 3hrs trying to get my bike running at a trial ,which would only run with choke on,and I bought super diesel,just a thought

Share this post


Link to post
Share on other sites

 The Kiehin carb can get a clogged pilot circuit that cannot be fixed. Number one quit blowing air, that is usually the thing people have in common when the carb becomes trashed. They all used air. Try contact cleaner , not carb cleaner  blown through the pilot circuit. There are two holes it should come out of, just under the slide and just in front of the slide. If these are not flowing then it is clogged internally. You could take the tower off. (The part with security torx screws) but beware the oring inside is unavailable. Another test would be to see if the tower leaks. Which you could submerse it  and blow air into the circuit. Trying another carb could help just to make sure where the issue is. Comepletly tearing down the carb,  and removing the tower and soaking the carb body in carb cleaner might fix it if you are lucky.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×