Jump to content

FanticRescue

Fantic 307 jetting

Recommended Posts

Hi there, can anyone give me a base line jetting for a Fantic 307 at sea level?

Full story: I've just gotten my first trials bike, a Fantic 307. It starts but it runs very irregularly, won't idle properly and finally bogs down. Compression gets up to 11 bar in 304 kicks, so that seems solid. Reed valves and intake boots look OK. I've changed the spark plug (the old one was at 0.4mm gap..?), the air filter and the air box cover rubbers.  Carb and jets looked clean enough, but it's time to have a second look at the carb. I suspect the float level is all over the place. The jetting seems weird as well, so I'd like to restore everything to stock. 

Edited by FanticRescue

Share this post


Link to post
Share on other sites

Hi there this brings back memories but not good ones,

I had a 307 new and never got it to run right fiddled with carb settings forever packed in first day of the six days as it just ran terrible.

Never got it sorted .

If I had one now I would get an OKO and try it I've one on and old Fantic Section  runs fine.

Sorry I'm little help sure there's others on here who've got them sorted,

Share this post


Link to post
Share on other sites

 Do a proper carb clean before chasing anything else. Suppose you have a Del Orto. Make sure the choke circuit is clear that is in the bottom of the float bowl and of course the pilot too.

  • Like 1

Share this post


Link to post
Share on other sites

If you have readily available supply (no supply issue) carburetor parts, that would suggest parts are a reasonable cost.

You might replace the needle and seat for the float. Why not if they are cheap? On again, off again "won't idle properly and finally bogs down" sounds like money well spent on those two parts.

If you own a number of bikes, have extra money etc, consider investing in an ultra sonic cleaner. Once you learn how to use it, and the many uses it has, you'll wonder why you never bought one before. On the TLR carburetor bodies alone it cleans them wonderfully well. Just be careful with some solvents and the heat the ultra sonic cleaners will/ can produce!

Good luck!

Share this post


Link to post
Share on other sites

Thanks for the advice guys. Rob from Eurocarb provided me with these data: 

We have 2 listings for the 307:-

Trial 307 89/90 PHBH26CS

  • 60 Slide
  • 9477.74  X74 Needle
  • 13270.274EG Atomiser/Needle jet
  • 6413.135 Main jet
  • 12530.36 Idle jet
  • 7746.70 Choke/starter jet
  • 8649.270 Float valve
  • 9010.2 6.5Gr floats

Trial 307 89 -French market PHBH26CS

  • 60 Slide
  • 9477.61  X61 Needle
  • 13270.274EG Atomiser/Needle jet
  • 6413.135 Main jet
  • 12530.38 Idle jet
  • 7746.70 Choke/starter jet
  • 8649.270 Float valve

I will take the carb apart and have a more thorough look. 

Edited by FanticRescue
  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, FanticRescue said:

Thanks for the advice guys. Rob from Eurocarb provided me with these data: 

We have 2 listings for the 307:-

Trial 307 89/90 PHBH26CS

  • 60 Slide
  • 9477.74  X74 Needle
  • 13270.274EG Atomiser/Needle jet
  • 6413.135 Main jet
  • 12530.36 Idle jet
  • 7746.70 Choke/starter jet
  • 8649.270 Float valve
  • 9010.2 6.5Gr floats

Trial 307 89 -French market PHBH26CS

  • 60 Slide
  • 9477.61  X61 Needle
  • 13270.274EG Atomiser/Needle jet
  • 6413.135 Main jet
  • 12530.38 Idle jet
  • 7746.70 Choke/starter jet
  • 8649.270 Float valve

I will take the carb apart and have a more thorough look. 

A proper person

  • Like 1

Share this post


Link to post
Share on other sites

Guys, I'm pretty sure the carb is sorted. Didn't use any new parts, because I'm cheap and it looked pretty good to start with. Jets are clean, float works.

....but the Fantic still won't run reliably. Really looks like an ignition problem now. It starts when cold, runs OK with the occassional hiccup and then suddenly dies after riding for 5 minutes never to start up again. Obviously at that point you keep kicking like a maniac, drown the thing, kick some more, slide off the tired kick starter, sprain your ankle and utter very, very naughty words. 

I can feel the gods of Italian motorcycles mocking me. Ha! Joke's on them, I've had a Cagiva with electronic injection and numerous other crappy 80s and 90s motorcycles. And these days I have access to a proper motorcycle workshop with lifts and heating and tools and compressed air........so bring it on. 

Ignition troubleshooting mode.....ENGAGE!!

When I spin up the crank with an electric drill the spark looks weak and irregular, like it skips every 8 rotations or so. When I hook up the multimeter to the leads from the stator these are the values. Mind you, resistance is measured statically and voltage is measured while running the crank with an electric drill. 

Brown - Red  5.0v (ac) and 111 ohm

Brown - White 5.6v (ac) and 0.6 ohm

Brown - Green 49.5v (ac) and 372 ohm

Lacking a proper manual...am I doing this correctly? Do these values look familiar? I've tried pulling the flywheel to figure out what is what but it's some exotic size I don't have lying around like 32.

Share this post


Link to post
Share on other sites

So, next part of the Fantic Fiasco. By now I've had the ignition source coil on the stator rebuilt by a local coil rebuilding guru. Two other companies wouldn't touch it. Guess putting on 3500 windings of 0.1mm copper wire is a specialty job, who would have thought. 

That fixed the weak and irregular spark. Starts on first kick and keeps running! Victory! I've also replaced the front brake pump with an AJP as I was unable to source a rebuild kit for the stock 10mm Brembo. Welded the holes in the header pipe, cleaned the brakes front and rear...

So yesterday and today I finally took the Fantic out to ride......and it's still not running properly. Throttle cable tends to get stuck and every now and then it loses power, bogs down and dies.

Back to the work shop. I might just rebuild the carb properly now, at the very least replace seals and float assembly and replace both inlet rubbers. Funny thing is that it still runs with the mixture screw all turned in, that can't be right. Fuel tap is suspect as well. 

Getting there. 

 

Edited by FanticRescue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×