Jump to content

timp

4t misfire 2018

Recommended Posts

Following on from this thread has anyone similar issues or cures?

Share this post


Link to post
Share on other sites

I’d suggest the easy things first.

1. Choke off

2. Air box doesn’t have a rag or something left in it

3. Replace sparking plug (perhaps the easiest?)

It could be just a  bad electrical connection, or poor earth connection on the coil.

Share this post


Link to post
Share on other sites

 The bike comes lean jetting wise. While you are in there you get to see if the intake boot is torn or not installed correctly.

Share this post


Link to post
Share on other sites

When the 4t first came out a friend had problems with the bike not running properly.  Turned out he was unaware of the hot start button and (I can't remember which way now) has assumed it was the choke and was running with the choke on all the time, or vice versa.  Worth checking they are both in the correct setting?

  • Like 1

Share this post


Link to post
Share on other sites

You  say if the bike is brand new.

If you bought from a dealer then the bike automatically comes with a six month warranty (even if bought from a dealer second hand).

I would suggest that the dealer should be your first call before taking the thing apart.

Share this post


Link to post
Share on other sites

Questions the supplying dealer may ask you are, “ have you broken the engines in?” Have you shared the same fuel? As all are misfiring it could be stale fuel. Are the bikes misfiring or are you revving them too high and the limiters operating.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×