Jump to content

the outlaw

320TL running rough. Crankshaft oil seals gone?

Recommended Posts

Any SWM / Rotax engine aficianados out there for some advice? I've recently acquired a very clean SWM 320TL which I suspect has had an easy life. The previous owner told me on collection that he thought it had picked up some sediment in the carb' having been sat for a couple of years, and I'd need to give it a good clean. I briefly ran it, and he was right, it was displaying the classic signs of a gummy carb and blocked pilot jet... it wouldn't run at low revs, needing choke to keep it alive as they dropped, though was okay at larger throttle openings. 

So, I fitted a new pilot jet, (a size 60, though I know some folk say a 65 is best) and cleaned the carb' including the other jets before reassembling it. I started it (first kick) but it was still running in the same way; that is it runs okay on the choke, but as soon as I drop the choke lever it starts faltering at low revs then failing to respond to the throttle and need the choke half applied to catch the revs before it dies. I rode it around the garden by keep it revving hoping things might clear when the revs were applied and the engine warmed up, but no, it fails to tick over without the idle wound in to keep the revs up.

I checked the carb' rubbers on the engine and air box side. They're sound, no pin holes or splits and with a good seal to the carb' and with no signs of air leaks.

My thoughts are that this might be the crankshaft oil seal(s) that are gone, but I'm unsure whether the failure to pick up from low revs is consistent with worn oil seals? There's no excess smoke so I doubt it can be sucking in oil. Air maybe though? Anyone got any advice to offer on this or perhaps experienced a similar issue?

Any advice would be much appreciated.

Share this post


Link to post
Share on other sites

I think it is still starving for fuel. I would pull the carb and make sure each passage is clear and open. Most of the time it will be blocked were you can not see.

I use carb cleaner and gently squirt it into each passage, if it blows back it is blocked. Sometimes you can shine a strong light into some passages and see it reflect even around a bend and light up the other end of the passage.

100% eliminate the carb before moving on.  Best of luck....dave

Share this post


Link to post
Share on other sites

The passages of the fuel screw can be clogged easily, even by some cloth lint while cleaning, might be worth a look.
The main jet should be 90 may be 100 depending to your climate?

Last not least you might look up if the air filter is not clogged or over oiled ore has started to dissolve,
or the perforated sheets where the filter is mounted in between are clogged
or last not least a too fine filter material is used.

The original filterfoam has to be pretty coarse and just very little oiled,
too much and the engine won't get enough air and will perform astmathic.

 

  • Like 1

Share this post


Link to post
Share on other sites

I'm also on board with a still dirty carb.  Replacing the pilot jet does nothing if the pilot jet passage is blocked, resulting in a running condition like you are describing.  Completely disassemble the carb, dunk it for over an hour in real carb cleaner (or get it sonic cleaned), rinse, blow out ALL passages with spray carb cleaner and compressed air.  Reassemble and enjoy!    :thumbup:

Got a pic of your new scoot? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×