Jump to content

Sign in to follow this  
nh014

2007 125 cc Rev3 Choke Problems

Recommended Posts

Having problems with a 2007 125 cc Rev3. Bike will not start when cold. It acts as though the choke is not functioning. If I give it a shot a starting fluid it will start first kick and once warm will start repeatedly with just one kick and continue to run without any problems. To date the stator has been replaced, crank seals replaced, a carb o-ring kit installed, and the carb (Dellorto) has been off and cleaned at least 4 times, with special attention to the choke circuit. With all that done it still will not start when cold unless I give it a shot of starting fluid first. Would appreciate and thoughts on what to look for.  

Share this post


Link to post
Share on other sites

 Quit wasting your time on starting fluid. Throw the damn thing on the ground. Jump up and down three times, saying piece of crap. Pick it back up and give it a good kick. Works every time.

Edited by lineaway

Share this post


Link to post
Share on other sites

 First why did someone put a Delorto on it ? Second it is the pilot circuit that is not working. There is a passage under the slide and in front of it. Third the choke passage in the float bowl has to be clear too.

 

 

 

 

 

Share this post


Link to post
Share on other sites

Lineaway, actually laying it on the ground did work once, since it evidently flooded the carb and then started. But that only worked once, Pilot circuit is clean as is the choke passage. I do have a spare Mikuni off of a 348 Montesa. I may re-jet that and try it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×