Jump to content

technomix

Carb Trouble?

Recommended Posts

Hello; I`ve got a problem with my 1998 Beta Techno. History of the bike is unknown; when I received the it was in pieces, and I just put it back together.

Problem is, the bike will start, but runs really "heavy", poor throttle response. Adjusting the idle and mixture screws has absolutely no effect, and it won`t idle. I pulled the plug, and it`s really wet and oily. Adjusted the carb float to reduce fuel in float bowl, no change. Took out the airf filter to give it more air, no change, still runs rich. Shut off the fuel petcock and run it for about 10 seconds, and the engine suddenly starts to rev like crazy, quickly turn the fuel petcock back on and it goes back to running rich again.

It`s got a Dellort carb on it with the following jets installed (bad eyesight so I could be mistaken!) Pilot 100, Main 54, Needle 262. Needle in the top clip at the moment.

Any and all advise appreciated, Thanks

Share this post


Link to post
Share on other sites
 

Clean the carb out with can of carb cleaner and a compressor, then clean it out, then again, and again, and once more for good luck.

If this doesn't sort it at least you will have a really clean carb.

Also, clean the fuel tank and fuel line. You don't want to dirty your nice clean carb.

Share this post


Link to post
Share on other sites
 
 

Gday, as far as I can tell from my parts books, that Techno should have a Mikuni fitted (my 99 certainly has). I'd say someone's has been "fixing" it. See if you can get a Mikuni from a later techno and fit that. It would solve your issues in one foul swoop. Carb swaps dont work easily as there is always setting up to be done.

Cheers,

Stork

Share this post


Link to post
Share on other sites
 

After cleaning my carb so it`s spotless, still no change for the better. I think STORK955 may have a good point. The engine and electrics are from a 1998, but the frame is a 1994. The only manual I have is for a 1994, and it shows the Dellorto carb. I`m starting to think that my friend gave me the wrong carb for this year motor. I`m going to see him on Sunday and try switching carbs and see what happens.

Thanks for the tip, I`ll let you know how it works out.

Share this post


Link to post
Share on other sites
 

Make sure your float do not have any fuel in them. I did have a problem with Del carb on a Gas Gas, the float did have some fuel inside.

Stef

Share this post


Link to post
Share on other sites
 
 

My bike is fixed!. My friend fired up the bike and it ran like a dream. Nothing to fix, it run`s great he says. He was quite amused when I told him that I had been using the choke in reverse!. This is the first time I`ve ever seen a carb where lever up = off. I had been starting the bike with the choke in the off position (up), then soon switching it to the on position, causing it to run rich. Oh well, if you can`t laugh at yourself, who can you laugh at!?

Thanks for all your input and advise, very much appreciated

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...