Jump to content

brianjonesphoto

05 4rt No Spark, Plug Dry

Recommended Posts

I spent some time putting around the yard last night and the bike ran perfectly for an hour or so. I attempted to go for a ride today. When I got to the trail head as usual I went to start the bike to warm up. It started on the second kick like it normally does, but only ran for a few seconds and died. I tried resetting the ECU and disconnected the kill switch to no avail. When I got the back home I pulled the plug and I can't see any spark I tried a new plug and still no spark. The plug is pretty dry after a few kick overs and there isn't much fresh gas smell coming out of the plug hole when checking for spark.

It was raining today and I transport the bike on a hitch hauler so I thought it might be water intrusion somewhere. I've gone through all the connectors around the R/R stack and coil. There's wasn't an excessive amount of water anywhere. the center pin of the BAS plug was a little corroded so I cleaned it up. I jumpered the outer 2 leads of the BAS and it didn't seem to make any difference. I pulled the BAS and is does rattle a little bit, but it also sounds like it filled with liquid. Is that normal? Am I jumpering it correctly Red/white to Green?

Any other thoughts of what might be the cause?

Thanks.

Share this post


Link to post
Share on other sites
 

 

It could be the fuel pump. I just went through this with a friend. we swapped tanks and it fired 2nd kick.

...........and they arn't cheap!!

Share this post


Link to post
Share on other sites
 

I got a chance to dive further into troubleshooting today. He good news is the fuel pump runs with an external power source. WIth everything connected except the R/R it still have no spark or squirt. I pulled the injector to verify there was no fuel.

Going through all the steps in the manual everything checks out accept the pulse generator which reads as an open circuit. I haven't pulled the side cover yet to check the wiring, but that is the next step.

Is there anything else that would cause no spark and no fuel?

Is there a flow chart anywhere of how the FI system on there bikes work?

Share this post


Link to post
Share on other sites
 

Thankfully this was easier and cheaper to fix than at first thought. It took longer to get the parts in hand than it did to actually get the bike rideable again. My pickup coil was the reason I wasn't getting spark or fuel. I assume the ECU didn't know the engine was even turning when I would kick it over. The only way to replace the pickup coil is to buy a complete stator assembly for $250-300. I really didn't want to have to do that since the knew the stator was good.

I started scouring sources online for pickup coils only to find out there weren't very many. I did find this spec list for Eletrexworld.co.uk http://www.electrexworld.co.uk/acatalog/Online_Catalogue_Pick_up_Coils_160.html that pointed me in the direction of what other bikes might have the same pickup. It ends up KTM sell their pickup coils as separate units for $68 new. Being a cheap ******* and not wanting to blow $70 on a hunch I found one on Ebay from a 04 450 exc. Once I had the KTM coil in hand it was almost identical to the stock unit except for the shape of the mounting plate to allow clearance for the stator wire hold down. A little file work and everything fit together perfectly. 2 kicks and it runs like a champ

If anyone ever has this issue the KTM part that I used is 59039034000 PULSER COIL KOKUSAN 4K3-A/B which is used on almost all KTM singles from 98-05.

I want to thank Dennis at OverlandTrial.biz and Don a Cascade Motorsports in Mission BC for letting me pick their brains and come to the conclusion that it was only the pickup coil and not something more complex.

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...