Jump to content

Sign in to follow this  
scarboroughbeta

Running Rough

Recommended Posts

Hi guys , My 2007 rev3 seems to of started running rough after 5 minutes of warming up there seems to be a clunking noise but the bike seems to run fine , after a hour or so of running it doesnt seem to idle properly , it just wants to cut out , Ive tried new plug , cleaning the carb and trying v power fuel

Share this post


Link to post
Share on other sites
 

is air filter exhaust ok anything happen last time out poss plug cap maybe but sounds like it could be running lean causing pinking ,so if carb and jets properly cleaned it could be an air leak or maybe crank seals but hard to say without seeing/hearing it

Share this post


Link to post
Share on other sites
 
 

water had crossed my mind ,could be from washing bike or it could be in the fuel ,clean carb out again removing all parts possible and use an air line or aerosol carb cleaner then drain fuel out frame either check and separate any water found or replace with fresh , to replace seals flywheel would need removing on right side ,on left clutch cover and crank drive would need to be removed but its more likely the carb at fault

Edited by zerorev3rev4

Share this post


Link to post
Share on other sites
 

When you drain the fuel remove the fuel tap and check the filter inside the tank I removed mine when it stuck one day and found a gunge over the filter Also check the tank breather and any in line filter These are easy to check before you delve into the motor

Share this post


Link to post
Share on other sites
 

Betas because they have bulky (as in thickish metal) aluminium fuel tanks tend to cool down a lot when not in use. This causes moisture in the air above the fuel to condense on the inside of the fuel tank. The moisture then settles out under the petrol and ends up as sludge on the filter or droplets in the bottom of the carb.

You could try a fuel conditioner (sold to prevent condensation / corrosion in lawnmowers) or put a small amount of methylated spirits (20 cc per litre) in your fuel to absorb the water.

Share this post


Link to post
Share on other sites
 

Thanks for your advice guys , tonight i have cleaned the carb , ive also cleaned the airbox which had abit of water in it so im going to look at sealing it abit better to prevent water from getting in , hopefully the carb clean will of solved it as a few particles of dirt came out.

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...