Jump to content

Sign in to follow this  
scarboroughbeta

Fuel

Recommended Posts

Hi guys why is it when my 2007 rev 3 is upright i dont get any loss of fuel , but when i leave it on its side stand idling for 5 minutes or more it starts leaking, not loads but leaves a little puddle

Share this post


Link to post
Share on other sites
 

Check your float height sounds like it maybe to high

Share this post


Link to post
Share on other sites
 
 

Float height adjustment is pinned at the top of the beta forum.

Share this post


Link to post
Share on other sites
 

I don't think it's float height

Even if it was adjusted wrong it should not overflow

And remember, it probably didn't do it new and now it does so something has changed and floats don't adjust themselves

So its needle sealing, it's the only wear item in the area and it will change with time

Replace the needle (it has opened and closed hundreds of thousands of times, it's tired)

Use a Q tip and a little tooth paste and polish up the seat and of course set the float height correctly

Share this post


Link to post
Share on other sites
 
 
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...