Jump to content

Sign in to follow this  
betasweden

Beta Evo 300 4T -17

Recommended Posts

Hi guys!

 

I have just received my new Beta 300 4T -17. I have always been riding 2T before.

But I don’t seems to get it to work properly.

 

It seems like it don’t get enough gas when i have full gas.

You can really feel it when you driving on the road on maybe 5th gear and quickly turn on full gas.

Or standing still and turn on full gas to jump up a large rock or something.

 

I have seen some older topics regarding the carb set up.

“Set the nail to the bottom slot” “turn the mixture screw” etc.

 

But does anyone have any experience regarding the 2017 or maybe 2016 Beta 4T?

Or is this problem for every Beta 4T?

 

Your help would be highly appreciated!

 

Br/ Daniel  

Share this post


Link to post
Share on other sites
 

I did know someone many years ago with a Beta fourstroke who was not aware that it had a well hidden button, I think to assist with hot starts (whatever it was it was not the choke). It ran properly once that was in the correct position.

Edited by 2stroke4stroke

Share this post


Link to post
Share on other sites
 

5th gear and turn the gas.

They have a cv carb. Works very well. The hot start lever if not home properly will make the bike run unevenly. Likewise if the choke is not fully down will make it run awful.

Run the machine in then look to getting the bosi tailpipe. Improves the power.

Share this post


Link to post
Share on other sites
 
 

Hi guys!

 

I have just received my new Beta 300 4T -17. I have always been riding 2T before.

But I don’t seems to get it to work properly.

 

It seems like it don’t get enough gas when i have full gas.

You can really feel it when you driving on the road on maybe 5th gear and quickly turn on full gas.

Or standing still and turn on full gas to jump up a large rock or something.

 

I have seen some older topics regarding the carb set up.

“Set the nail to the bottom slot” “turn the mixture screw” etc.

 

But does anyone have any experience regarding the 2017 or maybe 2016 Beta 4T?

Or is this problem for every Beta 4T?

 

Your help would be highly appreciated!

 

Br/ Daniel  

 

They come from the factory set lean. I just got a new 300 4t Factory and I put a 130 main and a 27.5 pilot jet in it and it runs great. I left the needle clip in the stock position. I put a remote mixture screw on when I did the jets and it's about 1.5 turns out. 93 octane pump gas runs fine. I live in Texas and we're at about 500' above sea level and the temps now are about 70 degrees f. Hope this helps.

 

Share this post


Link to post
Share on other sites
 
 
 

My 2016 300 factory almost killed me! It would run out of fuel while going up a steep incline with the throttle wide open. It came with a 120 main, on the middle neddle clip. Put in a 122.9 main jet with clip at bottom and it worked better, still would hesitate on w.f.o. Installed a 125.0 and it was pretty good. Now running a 127.5 main jet, with clip in middle position. Works great. Had trouble on hot starts. Started using the hot start button and now it starts great, hot or cold. I am running at a little above sea level - 500 meters.

Share this post


Link to post
Share on other sites
 
 

Hello,

Thanks i will try this!

So you did nothing with the needle?

I left the clip in the third groove from the top. That is how it came stock. I have no hesitation or lean indications. It runs great at any throttle position. I just checked and my mixture screw is 2 turns out.

Share this post


Link to post
Share on other sites
 

I left the clip in the third groove from the top. That is how it came stock. I have no hesitation or lean indications. It runs great at any throttle position. I just checked and my mixture screw is 2 turns out.

 

I have ordered an 130 Main and a 27,5 jet. Really hope i will have them before the weekend.

Will let you know how it runs after.

 

Thanks, for your help!! 

Share this post


Link to post
Share on other sites
 
 

Hello,

I changed to the 130 Main this weekend and work much better now! Thanks!

The 27,5 jet was already fitted from factory. So only one needed to be changed. (Nothing with the needle)

I have not fitted the Bosi Arrow exhausted yet. But people say it should be better and also better sound.

Share this post


Link to post
Share on other sites
 
On 2016-12-31 at 6:55 PM, retromlc said:

i have a 250 4/,does a pipe improve power? if so which one

Hello,

I have not fitted the Bosi Arrow exhausted yet. But people say it should be better and also better sound.

  • Like 1

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...