Jump to content

Sign in to follow this  
justjosh9

Beta evo 250 jumping out of gear?

Recommended Posts

Okay so it seems to happen regularly to me that my bike jumps out of second into neutral. It’s happened in a couple of sections and yesterday when I was at the top of a hill.. which lead to a painful crash. I’m always very wary of really clicking it up into second from first.. Is this a beta problem or just something on my bike. It doesn’t seem to happen to anyone else ?

 

im thinking of swapping it in for a gas gas anyway ?

Share this post


Link to post
Share on other sites
 

 I have never had a shifting problem on a Beta. `86 `89 `92 `95 `96 `97 `00`01`02`03 `06`10`16. I would bet you are hitting the shifter some how. Good luck with the Gasser. It does some things better. Rear brake and easier to get up under cut ledges. It breaks better too.

Share this post


Link to post
Share on other sites
 

I don’t think I’m clicking it out of gear, I think it’s just not in gear properly but it doesn’t jump out immediately Like how I got almost to the top of a bank then it decides it’s not in gear properly ?. 

 

Share this post


Link to post
Share on other sites
 

The Beta Evo 250 2013 and early 2014 had this issue.  It was the selector forks were too thin/springy.  They would jump out of first or second, mid section.  That was the main reason that I sold mine.

There was plenty written about it here perhaps three years ago.

Share this post


Link to post
Share on other sites
 

My 16 does it somebody suggested that I'm using the wrong oil or my clutch needs bled.i change up to 3rd then down to 2nd and it's never done it again!very unnerving when it does it halfway up a waterfall!

Share this post


Link to post
Share on other sites
 

I've had 4 Evo's 2Ts, and they have all had issues popping out of gear, both 1st and 2nd. It always seems to happen shortly after putting it in gear. So before I enter the section I try to ride around a bit in the gear I will be usuing. That has greatly reduced the popping out at a critical time.

Share this post


Link to post
Share on other sites
 
On 4/2/2018 at 8:48 PM, thesolidman1 said:

I've had 4 Evo's 2Ts, and they have all had issues popping out of gear, both 1st and 2nd. It always seems to happen shortly after putting it in gear. So before I enter the section I try to ride around a bit in the gear I will be usuing. That has greatly reduced the popping out at a critical time.

Yep, same problem on my 2013 300 2T, less likely to happen if i put it in first, rode a bit then snicked it into second. If i shifted from nuetral straight into second more likely to happen. My 2014 model did it less, and it has never happened on my 2017 250 2T.

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...