Jump to content

Franko01

Sherco 2006 290 no spark

Recommended Posts

Evening all,

 

just wonderd if a 05 stator will fit the 06 sherco 290? 

Got a no spark situation and after reading various hreads on here I have done some meter readings and think it could possibly be this. 

I have ordered a puller so should be able to see if it’s the woodrough key and eliminate that, however when I check the coil I get nothing. Is this also a common problem on these bikes?? ?

 

cheers 

Share this post


Link to post
Share on other sites
 

4 hours ago, Franko01 said:

Evening all,

 

just wonderd if a 05 stator will fit the 06 sherco 290? 

Got a no spark situation and after reading various hreads on here I have done some meter readings and think it could possibly be this. 

I have ordered a puller so should be able to see if it’s the woodrough key and eliminate that, however when I check the coil I get nothing. Is this also a common problem on these bikes?? ?

 

cheers 

Yes I’m afraid the stators are fragile and its not just Sherco’s that suffer. Do a search on this sites Sherco area. You can get the stator rewound.

Share this post


Link to post
Share on other sites
 
 

Ah ok cheers guys! I’ll let you know how I get on this week once the flywheel puller comes. ??⚙️

Share this post


Link to post
Share on other sites
 

Got the flywheel tool today and discovered this? Would dirt and grime be a factor at all?? 

EF4E9505-ACDF-44F1-BED9-7B1544C028EE.jpeg

Share this post


Link to post
Share on other sites
 

Just saw this slightly rusty terminal....another potential non sparking issue or is this normal? ??

24043116-5EB2-46A1-99B1-34A24627A837.jpeg

Share this post


Link to post
Share on other sites
 

I would assume the rusty coil was the 1 at the bottom? That shouldn't be the cause & neither will the dirt at the bottom of the cases. By all means clean everything but I doubt that is your problem

Scroll down this link to the readings you should have from the stator, usually 1 of them is a long way out if there is a problem

https://www.splatshop.co.uk/stator-repair-exchange-new-style.html

Share this post


Link to post
Share on other sites
 

Do just try changing the coil - much cheaper and worst is you end up with a spare coil.

I went through the whole stator fix rigmarole and it ended up being the coil. And make sure you get a genuine Leonelli replacement as the cheapo ones on eBay are a bit variable.

Share this post


Link to post
Share on other sites
 
18 hours ago, v1nn1e said:

Do just try changing the coil - much cheaper and worst is you end up with a spare coil.

I went through the whole stator fix rigmarole and it ended up being the coil. And make sure you get a genuine Leonelli replacement as the cheapo ones on eBay are a bit variable.

Hi ?? 

it all works now! Turns out the stator was completely dead and the coil was very very weak. So I got the stator fixed and a new leonelli coil and now it works like a dream! ✊?????

Share this post


Link to post
Share on other sites
 
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...