Jump to content

Johnst300

Sherco st300 radiator problems

Recommended Posts

Hello there, I have just purchased a 2014 st300 with a cracked radiator. I have replaced this with a brand new item filled her up with new coolant. When testing the bike after a few minutes of riding it got very hot and coolant started to bubble out of the ‘release valve’?? A little brass thing at the top next to the filler cap? Just wondering what people’s thoughts are?

 

thanks John

4F364126-C8A4-4CF5-959A-292B06D0F711.jpeg

CD7FE2E6-5E58-482D-923B-4CBA043F6BC3.jpeg

Share this post


Link to post
Share on other sites
 

It's the pressure relief valve letting excess pressure out of the rad.If it's getting really hot it might be air locked,is there a little bolt in the top of the head near the radiator hose which you need to loosen when you fill it ,there was on my Gasgas and is on my TRS.Splatshop will tell you,give them a call

Share this post


Link to post
Share on other sites
 
 
 

If all the components and parts are intact and working as they should and your still having the problems, those '14-'15 Factory 300's have an older  thread or two on this site with owners having problems with them from brand new.. Best of luck:thumbup:

Share this post


Link to post
Share on other sites
 
 

Fan and head gasket and water pump where nackered, fixed it then swapped for a 2020 4rt??

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...