Jump to content

stpauls

Sherco St Crank Seals

Recommended Posts

Hi

My 2012 ST is loosing oil.  Over a period of about 6 trials. plus practising, the oil level goes down from the 450ml that was put in the gearbox, to 200ml.  This has done this 3 times now.  The oil that comes out is very cloudy.  It is not loosing any coolant.   Additionally, despite running at 80-1 the bike has white smoke, which does not disappear even when hot.  I am thinking that it is a leaking crank seal.  Questions:

1. Do you agree that it is a crank seal?  

2.  If so, which side, or replace both?

3.  Do I need to remove or split the engine to replace the crank seals?

4.  Any instructions anywhere for replacing crank seals?

Thanks 

Edited by stpauls

Share this post


Link to post
Share on other sites
 

Hi there,

I m new here in Forum. I come from Germany and I have a Sherco ST 1.25 with exactly the same symptoms as you described. Did you solve this problem? Did you have to change the crankshaft seals? 

Thanks

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...