Jump to content

Sign in to follow this  
bashplate

ty175 carbie

Recommended Posts

Hey 175 guru's, just getting a 1976 up and running again. Starts first kick and ticks over like a swiss watch....but open throttle past 1/4 and it just dies out. Is this the classic "o" ring around the main jet problem, or something else. Carb has been stripped and carbie clean/airline blown out.

Share this post


Link to post
Share on other sites
 

Could be, but not enough info to know for sure.

How quickly is the throttle being opened?

What happens when you try it with the starting circuit in service?

It is doing the same thing hot and cold?

Share this post


Link to post
Share on other sites
 

Yeh, does it hot or cold. If turn throttle gently in lower gears up to 1/4 open, then motor revs cleanly, but go any more and will balk.

 

Share this post


Link to post
Share on other sites
 
 

Thanks Bmonk, I'll grab 1 when the dealer opens in New Year.....or will any 'o' ring the right size stand up to the fuel?

Share this post


Link to post
Share on other sites
 

I usually just tell the person behind the counter what it's for and they sell me an o ring made of the right stuff

  • Like 1

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×