Jump to content

Jlpettimore

Ty175 won't run

Recommended Posts

Hi al

Got a TY175 recently and nice looking bike. Starts OK but will only run for a few minutes then bogs down after riding for a few minutes.   When you let the clutch out when pulling away, doesn't want to go, bogs down and have to give it a lot of revs, but then eventually it dies and won't start again then.  

Any ideas?   I think carb related as repalced spark plug and air filter is clean. 

 

Many thanks! 

IMG_20200702_200025.jpg

Share this post


Link to post
Share on other sites
 

Exhaust blocked ? Does it stall if you let it idle for a while ? How does it sound when it run?

Guy

Share this post


Link to post
Share on other sites
 

Check the vent pipe on the fuel Filler cap isn’t blocked, if it is you’ll get a vacuum build up in the tank and fuel won’t flow into the carby.

 

Share this post


Link to post
Share on other sites
 
2 hours ago, paulmac said:

Check the vent pipe on the fuel Filler cap isn’t blocked, if it is you’ll get a vacuum build up in the tank and fuel won’t flow into the carby.

 

Thanks. Tried that but no joy. 

Share this post


Link to post
Share on other sites
 
3 hours ago, guy53 said:

Exhaust blocked ? Does it stall if you let it idle for a while ? How does it sound when it run?

Guy

It will idle OK. I took the exhaust baffle out and replaced it with a new one. Old one was totally choked up and oil sparking from it when running.  Still doing same though 🤷‍♂️ problem seems to be when you let the clutch out it just bogs down after running a while.  Then tops completely until the engine cools down. 

Share this post


Link to post
Share on other sites
 
 
 
 
 

yes had a similar problem with a 175, the wee o ring did the trick.

  • Thanks 1

Share this post


Link to post
Share on other sites
 

Sounds possibly like the sparks system breaking down with heat, it is like 40 odd years old, suggest confirm bared ht lead (no cap just end of lead after removing cap)  to engine metal test when it's broken, see if it can make 5mm gap when being kicked, if not suggest get electronic ignition kit.

  • Thanks 1

Share this post


Link to post
Share on other sites
 

Runs for a few minutes?  Is it running out of gas in the float bowl?  The reason I ask, it looks like a Sammy Miller gas tank-seat.  Fiberglass.  Fiberglass and some fuels just don't get along.  The fiberglass gets soft and  mixes in the tank and can clog thinks up.  Pull the fuel line off of the carb.  It should pour out.  if it drips, well you know.  Also..if that is a fiberglass tank, it should be coated to prevent it from being ruined by the fuel.  BTW   good looking bike.

  • Like 1

Share this post


Link to post
Share on other sites
 
 

As mentioned a while ago in other posts, Aspen fuel, while expensive is at least free of ethanol and so can be used in fibreglass tanks.

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...