Jump to content

Bernie Onthacoast

Sherco 2.5T no spark .

Recommended Posts

Hi Trails gurus . I have a Sherco 2.5T 2010 . the gas tank in the seat model . It has no spark after parking up from a ride , when i went to start it a day later there was no spark . From other threads here it does not seem uncommon . However when i tried to source a new stator i  am told its no longer available . My one appears to be off an earlier model 2007 , it has 3 windings and a trigger coil . it meters out ok as per specs i got here . 

Would anyone here know of the meter readings for the CDI . mine is the CDI coil in one, mounted behind the engine high in the frame. 

I have been quoted $ 690.00 NZD to upgrade to a 013 stator, coil, and CDI . I am reluctant to spend this untill i know exactly what has failed on my bike. Any help is appreciated. 

Cheers Bernie . Westport NZ 

IMG_3116.JPG

Share this post


Link to post
Share on other sites
 

That looks like the one in my 07 sherco iv just had it rewired and sorted for £135 12 month guarantee  so if you can find someone over there to do am sure that's your problem mine started 2nd kick after not working for over 12 months ...to replace mine would have been £420 ?

  • Like 1

Share this post


Link to post
Share on other sites
 
 
 

Send me a PM Bernie, I have a new stator like that from memory that I could possibly send to you to try when I get back from the Gold Coast next week 

  • Like 2

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...