Jump to content

vectradam

beta rev 4t - no spark

Recommended Posts

hi

i have no spark on my 2008 rev 4t. i have cleaned connections and earth etc.

can any one give me a procedure with some values to do some testing. i have a multimeter which i am familiar with.

many thanks

 

 

Share this post


Link to post
Share on other sites
 

this is the 'ignition generator check' as per an Evo 2013 4t manual (pg66) found on beta usa website under 'support'.....the check may be suitable for yours......

Disconnect black 12 way between the generator and CDI 

Disconnect the white 2 way connector between the generator and the wiring 

Black-White (pick-up) 320 ohm +/- 15%

Red-Blue (condenser charging) 15 ohm +/- 15% ......not sure the 2008 has a condenser/capacitor on it?

yellow-yellow (Service power supply) 0.6 ohm +/- 30%

after having stripped a Montesa 4rt and a beta 4t loom i'd say the wiring seems to be generally pretty poor on the beta so it could just be a bad connection. There are some wiring diagrams on the Beta usa sight that are readable but they are from later bikes -2014 onwards I think, but it may give you a clue...

good luck!

 

Share this post


Link to post
Share on other sites
 

Steps 1 and 2 when checking for spark         new spark plug,   and disconnect kill button      Then start with other checks.

Share this post


Link to post
Share on other sites
 

thanks very much for your help

tried new plug and removed kill switch but no change.

when you say 12 way connector thall1 i have a plug and socket  with 6 wires in and 6 out .

black - white    i have open circuit

yellow -  yellow - 0.6 ohms

red - blue - 15 ohms

so its looking like the pick up is finished.

anyone have any ideas of the best and cheapest solution ?

 

many thanks for your help

 

 

 

Share this post


Link to post
Share on other sites
 
 
14 minutes ago, 2stroke4stroke said:

There are two places in the UK that can replace such components.  Easily found by a search as I don't think I am permitted to name them on the forum.

You are, no problem unless you own one of said businesses

  • Like 1

Share this post


Link to post
Share on other sites
 

Give Steve a call at 'Uk Motoplat' 01209 482223.

or West Country windings on 01279 731172. 

Ive used Motoplat for a gas gas repair in the past.

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...