Jump to content

Karlosthejackel76

Fuelling issue

Recommended Posts

Hi im new to trials but have been racing enduro over the past 5 years or so. Ive bought an 09 sherco, ridden it for a couple of hours and it seems to have an over fuelling issue. I can potter about at 1/4 to 1/3 throttle no issues. Give it some beans- more throttle and higher revs up a hill or even on flat and it starts to bog and blue smoke losing all power and running crap. To me its like a worn needle or the jet is wrong. It takes then a few minutes of pottering about before it clears and runs clean at low throttle. Again if i open it up back to square one and rubs crap and smokes for a few mins. Ive not had carb apart yet but was gonna go straight in with a new needle and jet if there is a recommended jet and needle part number combo thats proven. Any help appreciated. 

Share this post


Link to post
Share on other sites
 

 
 
 

First step: New Spark plug

If not jetting then it could be the coil or CDI box.

 

 

Share this post


Link to post
Share on other sites
 
 

The tank is not in the wrong place, your looking at the bike from the wrong side.

Guy

Share this post


Link to post
Share on other sites
 
 
 

Just to let u all know i managed to have a look and the needle had been fitted the wrong side of the retainer so clearly now n again it was staying up rather than working with the slide. 

  • Like 1

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...