Jump to content

JonM

Another Tube/Tubeless Question

Recommended Posts

I had a Michelin front on a new bike and chased round the rim as you have done. Michelin replaced it, I would suggest you have a faulty tyre.

Edited by 2stroke4stroke

Share this post


Link to post
Share on other sites
 

31 minutes ago, 2stroke4stroke said:

I had a Michelin front on a new bike and chased round the rim as you have done. Michelin replaced it, I would suggest you have a faulty tyre.

I'm actually hoping it is that. 

At least it would explain what the problem is. 

Share this post


Link to post
Share on other sites
 

For anybody who's interested, here's the update:

Fitted a Michelin X-Light and at 50lbs it hadn't seated (although went on noticeably easier). 

I whipped it off and ran a Dremel with sanding attachment around the inner rim, and then went around it with 80grit emery paper. 

I just wanted to remove any tiny burrs or highspots I hadn't noticed. 

Tyre back on, pumped upto 60lbs and POP- on she went. 

I used a quality pressure gauge and that showed 58lbs, so we now have a seated tyre which went on at circa 58-60lbs. 

Whew. 

  • Like 3

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...