Jump to content

stephen123

Gasgas 300 back firing

Recommended Posts

 

Does it fire up? If not check the wudruff key or try a different spark plug..

 

  • Like 1

Share this post


Link to post
Share on other sites
 

When it starts it seems to run fine I've changed the plug a couple of times we bought the bike new but my lad put up with it    he now has given trials up so I've now inherited the bike and problem    could it be a faulty CDI unit thanks

Share this post


Link to post
Share on other sites
 

When CDI went on mine, it backfired badly. Clean the pick up first as they can also rust.

  • Like 1

Share this post


Link to post
Share on other sites
 

Ill will try that thanks but this has been doing it from brand new the bike is only 6 month old and at most only been used 10 times 

Share this post


Link to post
Share on other sites
 

If doing this from new might be running lean on the low end?  Maybe adjust the air/fuel setting and check what jets are in it and?

Share this post


Link to post
Share on other sites
 

If you have had it from new could you not seek advice from the dealer ( If they are open of course ! )

Share this post


Link to post
Share on other sites
 

Thanks for all your advice I have spoke to tony today (road and trials)he told me to check a few of the simple things first 

Like carb    done 

Spark plug      done 

Loose connection on plugs  done

I'm going to try to change my cdi unit of my 2014 if it fits and then who knows 

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...