Jump to content

pauls320

CDI failures

Recommended Posts

Whats the story on the CDI failures some owners  have been experiencing. Is it just a bad batch, water infiltration ,or.... ? Is this a ''warranty'' issue or out of pocket? :popcorn:

Share this post


Link to post
Share on other sites
 

my CDI went just a couple of weeks ago on my 2018 trs 300rr which is 1.5 years old, and I had to buy one, funny thing the CDI went on my 2016 trs one 300 at 1.5 years old and they replaced it but now they wont.

Share this post


Link to post
Share on other sites
 

 We have not seen a CDI issue here, but we are almost always dry. Only ride water a few times in the summer.

Share this post


Link to post
Share on other sites
 

Interesting, I read that they have improved the connector plug on the latest machines. Could the failures be contributed to a poorly designed plug on the cdi and water damaging the internals...possibly over use of a pressure washer here and there compounding problem? Be great to hear from factory tech or dealers take on this issue, just to clarify for potential purchasers and even current owners for something to be aware of.   

Share this post


Link to post
Share on other sites
 

The jet wash is contributing I think, we do this every weekend in the uk. A friend of mine has in recent years owned a trs a vertigo and a gas gas. He didn't have the TRS vey long but did replace the cdi on the vertigo and the gas gas.

All 2t manufacturers are fitting hidara ignition systems at the moment. Waterproof grease sounds a good idea, can anyone recommend a brand ?

Share this post


Link to post
Share on other sites
 
 
1 hour ago, tcrhino said:

A Vertigo doesn’t have a CDI box

Interesting.  I was just about to post saying that it was not uncommon to have CDI box problems on the RL250 Suzuki. The cure was to take them off and warm them up to dry out the internals. Just how the water got that deeply in is not clear as nobody really had a pressure washer in those days and the box was well protected under the tank. Worth a try?

 

Share this post


Link to post
Share on other sites
 

Is it down to water getting in the connector plug and shorting out perhaps.Some owners getting over keen with the jet washer maybe?

Share this post


Link to post
Share on other sites
 
11 hours ago, baldilocks said:

The jet wash is contributing I think, we do this every weekend in the uk. A friend of mine has in recent years owned a trs a vertigo and a gas gas. He didn't have the TRS vey long but did replace the cdi on the vertigo and the gas gas.

All 2t manufacturers are fitting hidara ignition systems at the moment. Waterproof grease sounds a good idea, can anyone recommend a brand ?

Any dielectric grease or silicone grease works well on electrics, clean all connections and apply liberally. 

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...